iTOP-3399开发板搭建Android编译坏境

发布时间:2020年01月16日 11:01    发布者:落风
基于迅为iTOP-3399开发板2.1 装 安装 d android  源码依赖包
登录进 Ubuntu 系统,输入“ctrl+alt+t”,打开超级终端,使用“su root”
命令,切换到 root 用户,如下图:

1.jpg

2.1.1  安装  JDK
Android8.1 系统编译依赖于 JAVA 8。编译之前需安装 OpenJDK。安装命令
如下:
sudo apt-get install openjdk-8-jdk
执行结果,如下图:

2.jpg

2.1.2 装 安装 d android  源码依赖包
使用如下命令安装所需的软件包:
sudo apt-get update
sudo apt-get install git-core gnupg flex bison gpeRF libsdl1.2-dev
libwxgtk3.0-dev build-essentialzip curl zlib1g-dev gcc-multilib
g++-multilib genromfs libc6-dev-i386 libncurses5-devx11proto-core-dev
libx11-dev ccache libgl1-mesa-dev libxml2-utils xsltproc unzip
lsb-corelib32z1-dev lib32ncurses5-dev texinfo mercurial subversion
whois liblz4-tool

3.jpg




欢迎分享本文,转载请保留出处:http://www.avcvq.com/thread-576927-1-1.html     【打印本页】
您需要登录后才可以发表评论 登录 | 立即注册

厂商推荐

关于我们  -  服务条款  -  使用指南  -  站点地图  -  友情链接  -  联系我们
电子工程网 © 版权所有   | 京公网安备11010502021702
回顶部